Simple Web Browser displays ":undefined"

:undefined/ displaying in the Simple Web Browser

All labs that use the “Simple Web Browser” setting are currently displaying “:undefined/” and then displaying a “404 page not found” error.

This is occurring in both the new and old HTML labs, although slightly different as a result of different configurations:

  • In the older HTML labs the starter URL is specified as {{localhost}}/{{entry}} which now displays as “:undefined/{{entry}}” where {{entry}} is the filename. This is occurring in both the preview and when launching a fresh project instance (which is an issue because these labs are live). This is confusing for users because simply removing the “:undefined/” portion of the URL and hitting the refresh button without pressing “enter” or “return” appears to have no impact. The user needs to hit “enter” or “return” while editing the URL for a change to appear which is not intuitive.

  • In new labs, the starting URL field can be made empty which yields the same “:undefined/” path in the preview, but when launching a new project URL , the browser will display the HTML page properly.

A quick fix would be to convert all the Browsers to have their “Simple” setting toggled off and the default browser starting URL set to {{localhost}}/{{entry}}. This is a priority because the older HTML labs are live.

Screenshot attached:

Annotation%202020-02-04%20133542

Hi @TroyDundas,

Thanks for letting us know — we’ll look into this right away.

This issue may now be resolved, please verify if it works for you.
image

1 Like

@Sevak
Good as new! Thanks for tackling that so quickly. Saved us a big headache.